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INTRODUCTION 

Misterine Studio is a desktop 

software for authoring AR technical 

manuals that are published to the 

Misterine App application. AR 

technical manuals combine the 

detailing of processes of a technical 

manual with a new way of 

presenting the visual information 

related to that process using 

Augmented Reality. This method 

presents visual cuing overlayed 

onto the physical environment in a 

manner that is fully embedded into 

the world. An example is shown in 

the image Figure 1. The colored 

parts are augmentations shown virtually being inserted into the physical cone below. At the upper right, the same 

physical part as the purple part is visible. The augmentations can also animate to show the user explicitly each task 

to be performed, here inserting the fitting and affixing with bolts and nuts seen on either side (green and orange 

colors respectively).  

 

To achieve this Misterine Studio has 

two main interfaces that work 

together to allow authoring of the 

AR technical manuals. The main 

Misterine Studio interface 

facilitates the creation of the 

Process that should be performed. 

Both creation of Processes by hand 

and via import of the industry 

standard S1000D definition of the 

process. A progress flow graph is a 

basis for editing the process and 

providing all related materials, like 

images, reference data, etc.  

An example of a Process that is 

created by importing an S1000D is 

shown on the Figure 2. In the center is the flow of this linear process. Validation of the flow is continually 

performed and displayed.  

Figure 1 Augmented reality 

Figure 2 Process definition 
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Each task may have a 3D scene 

attached to it, which is how the 

augmentations are defined. There 

is a specialized interface provided 

for this purpose. It is similar to user 

interfaces used in CAD and 3D 

modeling software.  

Figure 3 is an example of a 3D 

scene of one of the steps defined 

in the process. In this case we have 

a butterfly valve consisting of 

multiple parts. We see this in the 

center of the interface. This is the 

place where augmentations and 

animations are designer.  Figure 3 Scene definition 
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SYSTEM REQUIREMENTS 

- Windows 10 (10.0.17134) 

- At least 16GB RAM 

- At least NVidia 1050 or equivalent graphics card 

- At least 1GB of disk space available 

- Installation of .NET 3.5, .NET 4.8 and MICROSOFT VISUAL C++ REDISTRIBUTABLE X64 FOR VISUAL 

STUDIO 2015, 2017 AND 2019 (part of the installer) 

  

https://dotnet.microsoft.com/download/dotnet-framework/net35-sp1
https://dotnet.microsoft.com/download/dotnet-framework/net48
https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0
https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0
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INSTALLATION 

INSTALL MISTERINE STUDIO 

1. Run the misterine_studio_1.6.2.exe file 

2. Select the language 

3. Read the installation instructions of the setup wizard and click Next 

4. Accept the license agreement and click Next 

5. Wait for the prerequisites check and click Next 

6. Select the destination location for the installation and click Next 

7. Select additional tasks to be performed and click Next 

8. Click Install and wait for the end of the installation process 

9. Click Finish to exit the setup wizard 

UPGRADE MISTERINE STUDIO 

1. Run the misterine_studio_1.6.2.exe file 

2. Select the language 

3. Read the upgrade instructions of the setup wizard and click Next 

4. Wait for the prerequisites check and click Next 

5. Click Install and wait for the end of the upgrade process 

6. Click Finish to exit the setup wizard 

UNINSTALL MISTERINE STUDIO 

1. Run the misterine_studio_1.6.2.exe file 

2. Select the language 

3. Read the uninstallation instructions of the setup wizard and click Uninstall 

4. Click Yes to accept the uninstallation of the Misterine Studio 

5. Wait for the uninstallation process to be finished 

6. Click Ok to exit the setup wizard  
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UPDATE INSTALLATION 

Misterine Studio provides automatic check for update on a startup. It automatically opens a dialog if an update is 

available. It is also possible to check for update manually to install the update whenever it’s required. 

INSTALL UPDATE 

1. Go to Help > Check for Update 

2. Wait until the checking is finished 

3. If an update is available click Download 

4. Wait until the downloading is finished 

5. Click Exit and Install to automatically close Misterine Studio and install the update 

IGNORE UPDATE 

1. Go to Help > Check for Update 

2. Wait until the checking is finished 

3. If an update is available click Ignore to ignore this specific update until new one is available 
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LICENSE 

Misterine Studio supports two types of a license. The first type is Personal Edition, which is automatically set 

during the first run of the Misterine Studio. The second type is Full license and for its activation, the license ID and 

license activation code is needed. The table below shows features limitations based on the license type. 

 

  License type 

Personal Edition Full 

Fe
at

u
re

s 

Public server deployment 
✓ ✓ 

Public package 
✓ ✓ 

Custom server deployment 
✗ ✓ 

Private package 
✗ ✓ 

 

ONLINE ACTIVATION 

1. Go to Help > License 

2. Click Activate online or click arrow to the right and then choose Activate online 

3. Enter license ID, license activation code and optional installation name 

4. Click Activate 

ONLINE DEACTIVATION 

1. Go to Help > License 

2. Click Deactivate online or click arrow to the right and then choose Deactivate online 

3. Confirm deactivation and click Deactivate 

ONLINE REFRESH 

1. Go to Help > License 

2. Click Refresh online or click arrow to the right and then choose Refresh online 

MANUAL ACTIVATION 

1. Go to Help > License 

2. Click arrow to the right from Activate online and then choose Activate manually 

3. Enter license ID, license activation code and optional installation name 

4. Click Generate activation request 

5. Click Save to file or Copy to clipboard to store activation request in preferred way 
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6. Click Open activation page 

7. Follow instructions on the activation webpage for obtaining activation response 

8. Click Load from file or Paste from clipboard to get obtained activation response back to the form 

9. Click Activate 

MANUAL DEACTIVATION 

1. Go to Help > License 

2. Click arrow to the right from Deactivate online and then choose Deactivate manually 

3. Click Save to file or Copy to clipboard to store deactivation request in preferred way 

4. Click Open deactivation page 

5. Follow instructions on the deactivation webpage for obtaining deactivation response 

6. Click Load from file or Paste from clipboard to get obtained deactivation response back to the form 

7. Click Deactivate 

8. Confirm deactivation and click Deactivate 

MANUAL REFRESH 

1. Go to Help > License 

2. Click arrow to the right from Refresh online and then choose Refresh manually 

3. Click Save to file or Copy to clipboard to store refresh request in preferred way 

4. Click Open refresh page 

5. Follow instructions on the refresh webpage for obtaining refresh response 

6. Click Load from file or Paste from clipboard to get obtained refresh response back to the form 

7. Click Refresh  



11 
 

Misterine Studio User Manual V1.6.2 ©2023 Misterine s.r.o. 

USER INTERFACE OVERVIEW 

Misterine Studio interface can be visually separated into left, central, and right sections. Each section contains 

modules which are numbered and presented in the Figure 4. The layout of the modules can be modified by the 

user, the examples given are reflecting the default layout of Misterine Studio. 

 

 

Figure 4 Misterine Studio UI 

1. Project Explorer shows the tree of project items presented as processes, resources, and scene templates. 

The module is responsible for creating, deleting, updating, and viewing project items. 

2. Project Item Preview shows base information for the currently selected item in Project Explorer. Preview 

can be shown for five project item types: Process, Image file, PDF file, XML file, and TXT file.  

3. Process Designer shows the current diagram of an opened process. The module allows to add, delete, 

update, and connect process elements.   

4. Toolbox holds the allowed process elements which can be added to a process diagram.  

5. Process Item Details shows the detailed information of a current selected process element. In case when 

no process element is selected the module displays several tabs with detailed information about process 

and its components: ‘Process Overview’, ‘Safety Requirements’, ‘Figures’, ‘Equipment’, ‘Spares’, 

‘Supplies’, ‘Pre-Conditions’, ‘Post-Conditions’, ‘Reference Table’.  

6. Process Validation displays the warnings and errors which were found during the process creation. A 

process cannot be deployed if it contains errors. 

7. Global Search allows to perform the word searching among the whole project. The module supports 

three searching regimes: ‘Match Case’, ‘Match Whole Word’, and ‘Use Regular Expression’. All regimes 
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can be used simultaneously. In case of successful search, the module shows the result tree which contains 

the path from the process to the element that contains the searched word.   
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PROJECT MANAGEMENT 

Projects in Misterine Studio are a collection of processes, scenes and resources. Items in projects can be 

interconnected and referenced. The majority of project management operations are performed from the Project 

Explorer. Every project will create a physical folder on the disk named after the Project name. This folder will 

contain the project file (with .vip extension) as well as other project files. 

 

PROJECT 

CREATE A NEW PROJECT 

1. Go to Project > New Project 

2. Enter the project name and location  

3. Click Finish 

OPEN AN EXISTING PROJECT  

4. Go to Project > Open Project 

5. Navigate to the “.vip” project file 

6. Click Open 

OPEN A RECENTLY OPENED PROJECT 

1. Go to Project > Recent Projects 

2. Click the project to open 

CLOSE THE CURRENTLY OPENED PROJECT  

1. Go to Project > Close Project 

or 

1. Right click the project in Project Explorer 

2. Click Close project 

 

RESOURCES 

Resources are external files imported into the project. Misterine Studio keeps track of two kinds of resources, 

source files and true resources. For large projects, it is possible to organize the project resources by creating and 

using folders. 

Source files include S1000D XML files and TXT files. 

IMPORT RESOURCES TO PROJECT  

1. Select resource folder you want to import the file to 
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2. Go to Project > Import > Import File 

3. Navigate to the file 

4. Click Open 

or 

1. Right click the Resources folder (or any subfolder) 

2. Click Import File 

3. Navigate to the file 

4. Click Open 

CREATE SUBFOLDERS FOR RESOURCES  

1. Select resource folder under which you want to create the folder 

2. Go to Project > Create Folder 

3. Name the newly created folder in the Project Explorer 

or 

1. Right click the resource folder under which you want to create the folder 

2. Click Create Folder 

3. Name the newly created folder 

SET RESOURCE ACCESS RIGHTS  

1. Right click a resource 

2. Go to Access Rights > Shareable 

3. Check the button to set the resource as Shareable, uncheck to make the resource Private 

PREVIEW RESOURCE 

1. Right click a resource 

2. Click Preview Resource / Preview Image  
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PROCESS DEFINITION 

Processes are defined using the visual interface in the Process Designer.  

 

PROCESS MANAGEMENT 

CREATE NEW EMPTY PROCESS 

1. Right click the Processes folder in Project Explorer 

2. Choose Create New Empty Process 

3. Name the newly created process 

or 

1. Go to Process > Create New Empty Process 

2. Name the newly created process 

CREATE PROCESS FROM IMPORTED TEXT RESOURCE 

1. Right click the text resource in Project Explorer 

2. Choose Convert to Process 

3. Wait for the action to finish 

4. Name the newly created process 

CREATE PROCESS FROM IMPORTED S1000D RESOURCE 

1. Right click the S1000D resource in Project Explorer 

2. Choose Create New Process from S1000D 

3. Wait for the action to finish 

4. Name the newly created process 

CREATE PROCESS FROM S1000D FILE ON DISK  

1. Right click the Resources or any subfolder in Project Explorer 

2. Choose Import S1000D 

3. Navigate to the S1000D file 

4. Click Open 

5. Resolve any missing images (see Resolve missing image during S1000D file import) 

6. Wait for the action to finish 

7. Name the newly create process 
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RESOLVE MISSING IMAGE DURING S1000D FILE IMPORT  

1. Choose to either use existing resource or import new one 

RESOLVE BY CREATING A NEW RESOURCE 

2. Choose name for the new resource 

3. Click the  icon and navigate to the image file 

4. Choose optional settings (searching in selected directories, etc.) 

5. Click Next and repeat for other images 

RESOLVE USING EXISTING RESOURCE 

2. Choose resource image from the list 

3. Click Next and repeat for other images 

OPEN PROCESS 

1. Double click the process in Project Explorer 

or 

1. Right click the process in Project Explorer 

2. Choose Open 

 

PROCESS WORKFLOW DEFINITION 

The process starts with the Start node and ends with the End node. The arrows of the graph define the order of 

tasks that the user should perform.  

The elementary unit of work the user should do is called a Task (also known as a step). A sequence of Tasks and 

other nodes in the graph define the instruction manual flow. Besides Tasks, there are other types of nodes in the 

graph. 

 

Start event indicates where a Process starts. A process must have exactly one Start Event 

node. Start Event nodes also exist in Sub-Processes, but outside of Sub-Processes, there might 

be just one. Other than the logical beginning of the process, the Start Event node has no other 

practical visualization. 

 

End event node indicates the end of the Process. It is a logical node for the purposes of 

indicating the end and it has no other practical visualization. End nodes exist also in Sub-

Processes, described below.  

 

Tasks are the fundamental work that the Misterine App user does. These are often called 

steps for a procedure.  
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Sub-Process is a logical separator in a Process. Typically, it is used to hold a complex task that 

is logically one thing, but requires the user to perform multiple individual tasks. Sub-Processes 

can be embedded up to 8 levels. A Sub-Process must always contain a Start, End and at least 

one Task. 

 

Decision points are places where different sets of Tasks could be required based on some 

choice. This is a single input node with at least two outgoing directions (1:N). In the current 

implementation, there is only one way to "resolve" the decision, a Simple Form, which is just a 

question with multiple answers that the user themselves decide. These will be described more 

below. 

 

Connection points are logical blocks that collect multiple input streams into a single outward 

direction (N:1). They are used in conjunction with Decision Points. The Misterine App user will 

not directly experience these nodes. 

 

Camera evidence node allows user of Misterine App to take photo of the current state during 

a running process. Those photos are then a part of the final report shown at the end of the 

process. 

ADD NODE INTO THE PROCESS  

1. Drag & Drop the node from the Toolbox window into the Process Designer 

or 

1. Click the node to enter Add Node Mode 

2. Add nodes by clicking on the Process Designer 

3. End operation by right clicking, pressing the ESC key or clicking outside of the window 

DELETE NODE 

1. Right click the node 

2. Choose Delete 

or 

1. Select the node 

2. Use the keyboard shortcut specified in Keyboard Shortcuts 

DUPLICATE NODE 

1. Right click the node 

2. Choose Duplicate 

or 

1. Select the node 

2. Use the keyboard shortcut specified in Keyboard Shortcuts 
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CONNECT NODES IN SEQUENCE 

 

Figure 5 Node input / output 

1. Click and drag from the Output of one task 

2. Drag over and release over the Input of another task 

Some nodes only provide an Input field or an Output point. Some nodes have multiple output points. 

 

TASK / SUBPROCESS DETAILS 

Access task / subprocess details by selecting a task in Process Designer. 

ADD WARNINGS / CAUTIONS TO TASK 

1. Select the task in Process Designer 

2. Click the  button in the warnings / cautions section of Task Detail 

3. Enter the warning message  

REORDER WARNINGS / CAUTIONS 

1. Select the task in Process Designer 

2. Move the items up and down in the list by using the  buttons 

The warnings / cautions are displayed in the order from top to bottom in Misterine App. 

 

DECISION POINT DETAILS 

Access decision point details by selecting a decision point in the Process Designer. Newly created decision points 

come with two outputs and one resolution method present as default. 

ADD AN OUTPUT POINT 

1. Select the decision point in Process Designer 

2. Click the  button in the Outputs section 

3. Enter the name and description of the output 

or 

1. Right click the decision point in Process Designer 

2. Choose Create Output 
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3. Enter the name and the description of the output 

ADD A RESOLUTION METHOD 

1. Select the decision point in Process Designer 

2. Click the  button in the Resolution Method section 

3. Enter the question  

4. Specify options 

ADD OPTIONS TO RESOLUTION METHOD  

1. Select the decision point in Process Designer 

2. Click the  button in the Options section 

3. Enter description and choose one of the defined outputs 

Each option must have a defined output. This specified which path of the workflow is followed when the user 

in App chooses a specific option. 
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PROCESS DETAILS 

Process details panel manages basic process information, all the equipment, tools and spares that are needed for 

the process and other resources. 

 

PROCESS THUMBNAIL  

Process Thumbnail is basic visual representation of a Process. In Misterine App, all available Processes are 

displayed in a list and thumbnail helps to find a Process more quickly. 

ADD OR CHANGE PROCESS THUMBNAIL  

1. Click Process Overview tab in process detail 

2. Move mouse over image editor at the top 

3. Click  (or  when changing) to open Resource picker 

4. Select an existing Image Resource or add a new one by clicking  button 

5. Press Ok 

DELETE PROCESS THUMBNAIL  

1. Click Process Overview tab in process detail 

2. Move mouse over image editor at the top 

3. Click  to delete 

 

PROCESS TAGS 

Process tags help categorize a process. Those tags are then very useful when searching for specific processes from 

the area of interest in Misterine App. 

CREATE TAG 

1. Click Process Overview tab in process detail 

2. In Tags section write an arbitrary Tag text (keyword) 

3. Click  button to add Tag with prepared text 

If Tag with the same text already exists, instead of creating a new Tag, the existing one is highlighted. 

REMOVE TAG 

1. Find Tag to remove in all listed tags in Tags section at the top 

2. Click  to remove specific Tag 
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PROCESS RESOURCES 

Process resources are a subset of project resources that will be propagated together with the deployed process. 
These will then be available in the end device. 

 

ADD NEW PROCESS RESOURCE  

1. Click the  button in the Resources tab of Process Details 

2. Select an existing resource from the list or import a new resource using the  

3. Click OK 

Or 

1. Locate the resource for import in the Project Explorer 

2. Drag and drop the resource onto the Resources panel 
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SCENE DEFINITION 

SCENES 

CREATE NEW SCENE 
1. Right click the task in Process Designer 

2. Choose Add 3D scene 

or 

1. Select the task in Process Designer 

2. Click the   button in the Process Designer toolbar 

OPEN SCENE 
1. Right click the task with a scene in Process Designer 

2. Choose Open 3D scene 

or 

1. Select the task with a scene in Process Designer 

2. Click the  button in the Process Designer toolbar 

or 

1. Double click the task with a scene in Process Designer 

DELETE SCENE 
1. Right click the task with a scene in Process Designer 

2. Choose Remove 3D scene 

or 

1. Select the task with a scene in Process Designer 

2. Click the  button in the Process Designer toolbar 

PROPAGATE SCENE 

1. Right click a connection connected to at least one Task in Process Designer or select the connection and 

go to Scene Assistant  

2. Choose 

a. Propagate Scene Forward to propagate the left Task’s scene to the right Task. 

b. Propagate Scene to End to propagate the left Task’s scene to all subsequent Tasks until it’s 

impossible to continue (missing connection, end of flow). 

c. Propagate Scene Backward to propagate the right Task’s scene to the left Task. 
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d. Propagate Scene to Beginning to propagate the right Task’s scene to all preceding Tasks until it’s 

impossible to continue (missing connection, start of flow). 

Propagation to the end or to the beginning opens dialog displaying current progress of the operation. 

Propagation to the end or to the beginning skips Tasks with already added scenes automatically. 

 

SCENE TEMPLATES 

Scene Templates are 3D augmentation scenes without relations to any processes or tasks. Instead, these templates 

serve as a base for any future scenes created on the tasks in a given project. 

Many Scene Templates can exist in the project but only one can be set as the default template. By default, any new 

scene created in a Task will create a copy of this default template. This behavior may be changed in Preferences. 

 

CREATE SCENE TEMPLATE 

1. Right click the Scene Templates folder in Project Explorer 

2. Choose Create new scene template 

3. Rename the newly created template 

OPEN SCENE TEMPLATE  

1. Right click the scene template in Project Explorer 

2. Choose Open Scene 

or 

1. Double click the scene template in Project Explorer 

DUPLICATE SCENE TEMPLATE  

1. Right click the scene template in Project Explorer 

2. Choose Duplicate 

ADD SCENE TEMPLATE TO AN EXISTING TASK  

1. Select the task in Process Designer 

2. Right click the scene template in Project Explorer 

3. Choose Add to Selected Task 

or 

1. Drag & drop the scene template from Project Explorer onto the task in Process Designer 
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TURN EXISTING SCENE ON A TASK INTO A SCENE TEMPLATE 

1. Right click task with scene in Process Designer 

2. Choose Make Template Scene 

or 

1. Select the task with scene in Process Designer 

2. Click the  button in Process Designer toolbar 

MARK A SCENE TEMPLATE AS DEFAULT  

1. Right click a non-default scene template in Project Explorer 

2. Choose Set Default 
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SCENE INTERFACE OVERVIEW 

The interface of the scene editor has 6 different windows with the most important 3D view in the center. 

Figure 6 Misterine Studio Scene Designer UI 

1. Use Scene explorer to select and filter objects in the scene. This window is shared for Asset explorer, 

Material explorer and Groups. 

2. Property editor displays properties of current selection. Some properties can be even shared in multi 

selection. 

3. The scene editor has multiple tools to help with positioning of objects with gizmos being the most 

prominent. When you select a tool, its properties will be shown in Tool window. 

4. The Timeline is used to create and position animations. The orange-colored strip represents an animation. 

A blue color represents a generator and a red color is used for a keyframed clip. 

5. When an animation clip is selected, its properties are shown in the Animator. 

6. Scene View where all visual components are displayed. Window is also shared with Note Editor for 

editing Note objects in a Scene. 
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SCENE CREATION 

SCENE OBJECTS  

A scene object is every object that is represented as a single item in the Scene Explorer. That can be, e.g., imported 

model node, tracking marker, label, positioning node, etc. 

SELECT SCENE OBJECT 

1. Click the one of the following buttons  in the Scene Designer toolbar or use the keyboard 

shortcut specified in Keyboard Shortcuts 

2. Select on or more scene objects by clicking on the nodes in the Scene Explorer or by clicking on the 3D 

models in the Scene View 

It is possible to select multiple scene objects using keyboard shortcuts specified in Keyboard Shortcuts. 

SELECT CONNECTED OBJECTS 

1. Open context menu in Scene Explorer and select Select connected  

Or 

1. Select an object while holding Ctrl+Alt 

Or 

1. While having a selection, press Alt+L 

Connected object means, the objects have intersecting bounding boxes. These bounding boxes are tight fitting 

oriented bounding boxes based on the original mesh. 

MOVE SCENE OBJECT 

1. Drag & Drop the selected scene object(s) in the Scene Explorer between two scene objects to insert them 

at that position 

 

Figure 7 Move scene object(s) between nodes 

or 

1. Drag & Drop the selected scene object(s) in the Scene Explorer to another scene object to insert them as 

last children of that scene object 
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Figure 8 Move scene object(s) under a node 

Move operation will not be applied to the selected nodes that violate any of the following rules: 

• A scene object cannot be moved under itself or its descendant 

• Some scene objects like labels, tracking markers, interactive anchors cannot be moved under other 

scene objects 

• Some scene objects like labels, tracking markers, interactive anchors, and notes cannot become a target 

of a move operation 

SET NAME 

1. Select one or more scene objects in the Scene Explorer or the Scene View 

a. Enter the scene object name in the Property Editor to rename all the selected nodes 

 

Figure 9 Set scene object name in the Property editor 

Or 

a. Right-click one of the selected nodes to open the context menu 

b. Select Rename context menu option 

Or 

a. Press F2 key 

 

Figure 10 Set scene object name in the Scene Explorer 

2. Enter a new name 

SET LAYER 

1. Select a scene object in the Scene Explorer or the Scene View 

2. Click on one of the following available buttons to add the scene object to the proper 

layer or remove it from that layer 



28 
 

Misterine Studio User Manual V1.6.2 ©2023 Misterine s.r.o. 

Scene objects can be moved only to some layers based on their type. 

B – Background 

T – Tracking 

C – Context 

F – Foreground 

SET VISIBILITY 

1. Select a scene object in the Scene Explorer or the Scene View 

2. Click the  button in the Property Editor 

3. A dialog appears if the visibility is turned on and at least one of the predecessors is not visible. 

4. Click Yes if you want to turn on the visibility of all predecessors or click No if you want to turn the visibility 

on only for the selected scene object 

or 

1. Click the  button of the corresponding scene object in the Scene Explorer 

SHOW SELECTED 

1. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

HIDE SELECTED 

1. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

HIDE UNSELECTED 

1. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

TRANSLATE SCENE OBJECT 

1. Select a scene object in the Scene Explorer or the Scene View 

2. Enter the translation vector value in the Property Editor 

 

Figure 11 Translate scene object 
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TRANSLATE SCENE OBJECT USING GIZMO OR MOVE TOOL  

1. Select a scene object in the Scene Explorer or the Scene View 

2. Click the   button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

3. Toggle the button in the Scene Designer toolbar to select the desired translation 

mode 

a. Drag translation gizmo to translate the scene object along one or two axes to the desired 

location 

 

Figure 12 Translate scene object using gizmo 

b. Enter the global position or a vector to move the scene object along axis in the Tool Window 

 

Figure 13 Translate scene object using move tool 

ROTATE SCENE OBJECT 

1. Select a scene object in the Scene Explorer or the Scene View 

2. Enter the rotation vector value in the Property Editor 

 

Figure 14 Rotate scene object 
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This action may not be available for some scene object types. 

ROTATE SCENE OBJECT USING GIZMO OR ROTATE TOOL  

1. Select a scene object in the Scene Explorer or the Scene View 

2. Click the   button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

3. Toggle the button in the Scene Designer toolbar to select the desired center of 

rotation 

4. Toggle the button in the Scene Designer toolbar to select the desired rotation 

mode 

a. Drag rotation gizmo to rotate the scene object around one axis to the desired position 

 

Figure 15 Rotate scene object using gizmo 

a. Enter the global rotation or a vector to rotate the scene object along axis in the Tool Window 

 

Figure 16 Rotate scene object using rotate tool 

SCALE SCENE OBJECT 

1. Select a scene object in the Scene Explorer or the Scene View 
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2. Enter the scale vector value in the Property Editor 

  

Figure 17 Scale scene object 

This action may not be available for some scene object types. 

Scaling can be done only in local space. 

SCALE SCENE OBJECT USING GIZMO  

1. Select a scene object in the Scene Explorer or the Scene View 

2. Click the   button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

3. Drag scale gizmo to scale the scene object along one, two, or all axes to the desired extent 

 

Figure 18 Scale scene object using gizmo 

Scaling can be done only in local space. 

STORE TRANSFORMATION 

It is possible to store (and reapply) the whole transformation once per each object. 

 

Store the transformation: 

1. Select an object and go to Property Editor 

2. Press  to remember the current transform. 
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Reapply the transformation: 

1. Select an object and go to Property Editor 

2. Press  to restore the remembered transform. 

DELETE SCENE OBJECT 

Deleting scene object removes the selection and it’s children from the hierarchy. 

1. Select one or more scene objects in the Scene Explorer or the Scene View 

2. Click the   button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

or 

1. Right click the scene object in the Scene Explorer 

2. Choose Delete 

DISSOLVE SCENE OBJECT 

Dissolving the object removes only the selected objects from the hierarchy and tries to reparent the children of the 

deleted nodes. 

1. Select one or more scene objects in the Scene Explorer or the Scene View 

2. Right click the scene object in the Scene Explorer 

3. Choose Dissolve delete, or use the keyboard shortcut Ctrl+Delete 

MOVE SELECTED OBJECTS TO ORIGIN  

1. Select a scene object in the Scene Explorer or the Scene View 

2. Click the   button in the Scene Designer toolbar 

DECIMATE SELECTED OBJECT(S) 

1. Click the   button in the Scene Designer toolbar 

2. Set the proper decimation settings parameters 

3. Click Decimate 
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Figure 19 Decimation settings 

SELECT SIMILAR OBJECT(S)  

1. Right click the selected object in Scene Explorer to open context menu 

2. Click the Select similar context menu option 

3. Select one or more of the following options 

a. Select similar object(s) by name 

1. Check the Name checkbox 

2. Enter a text or a regular expression to the input field to search nodes by name 

b. Select similar object(s) by oriented bounding box size 

1. Check the Oriented bounding box size checkbox to select the objects that have the same 

size of their oriented bounding box 

c. Select similar object(s) by shape 

1. Check the Same shape checkbox to select the objects that share the same instance of 

geometry 

d. Select similar object(s) by material 

1. Check the Same material checkbox to select the objects that have the same material 

e. Restrict search space 

1. Select Search siblings option to restrict the search space to the siblings of the respective 

object (objects having the same parent) 

Or 

1. Select Assembly relationship option to restrict the search space to the connected 

objects (with intersecting oriented bounding boxes) 

2. Enter the depth to limit the transitive search of the connected nodes 

4. Press the Select button to initiate the search. The objects matching the conditions will be added to the 

current selection. 
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Figure 20 Select similar dialog 

 

NAMED SELECTION SETS 

CREATE SELECTION SET 

1. Select scene object that should be in a Selection Set 

2. Right click one of the selected objects 

3. Choose Create named selection set 

or 

2. Go to Groups tab 

3. Click  button to create Selection Set from current selection in Scene Explorer 

or 

2. Press CTRL + G to create Selection Set 

Every Selection Set is unique. It’s not possible to create another Selection Set with the same content. 

RENAME SELECTION SET 

1. Select Selection Set 

2. Right click the Selection Set 

3. Choose Rename 
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4. Rename to desired name 

5. Unselect or press Enter to confirm changes 

REMOVE SELECTION SET 

1. Select Selection Set 

2. Click  button to remove the Selection Set 

UPDATE SELECTION SET 

1. In Groups tab select Selection Set 

2. Modify current selection in Scene Explorer or Scene View 

3. Right click the selected Selection Set 

4. Choose Update selection 

If the Selection Set is modified (but not confirmed) to already existing Selection Set, the existing Selection Set is 

automatically selected and the first Selection Set remains unmodified. 

SELECT SELECTION SET 

1. In Groups tab select Selection Set 

or (if already selected) 

1. Right click Selection Set 

2. Choose Select 

 

MODELS 

LIST OF SUPPORTED MODEL FORMATS  

Some of the formats may have multiple versions and not all of them are supported. 

CAD EXCHANGE FORMATS  

• DXF 

• STEP 

o Supported Application Protocols: AP203 (Ed2), AP214 (Ed3); 

o Implementation method: p21-File (Physical STEP File: ISO 10303-21); 

https://www.iso.org/standard/44305.html
https://www.iso.org/standard/43669.html
https://en.wikipedia.org/wiki/ISO_10303-21
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SUPPORTED 3D GRAPHICS FORMATS  

• '.3d', '.3ds', '.3mf', '.ac', '.ac3d', '.acc', '.amf', '.ase', '.ask', '.assbin', '.b3d', '.blend', '.bvh', '.cob', '.csm', 

'.dae', '.dxf', '.enff', '.fbx', '.glb', '.gltf', '.hmp', '.ifc', '.ifczip', '.irr', '.irrmesh', '.lwo', '.lws', '.lxo', '.md2', 

'.md3', '.md5anim', '.md5camera', '.md5mesh', '.mdc', '.mdl', '.mesh', '.mesh.xml', '.mot', '.ms3d', '.ndo', 

'.nff', '.obj', '.off', '.ogex', '.pk3', '.ply', '.pmx', '.prj', '.q3o', '.q3s', '.raw', '.scn', '.sib', '.smd', '.stl', '.ter', '.uc', 

'.vta', '.x', '.x3d', '.x3db', '.xgl', '.xml', '.zgl' 

IMPORT NEW MODEL 

1. Use the keyboard shortcut specified in Keyboard Shortcuts 

2. Navigate to the file 

3. Click Open 

or 

1. Click the  button in the Scene Designer toolbar 

2. Navigate to the file 

3. Click Open 

or 

1. Drag & Drop the file into the Scene Explorer or the Scene View 

TESSELLATION SETTINGS 

This dialog may appear during model import when a tessellation of imported model geometry is required. 

1. Change the Angular and Linear deflection values if needed 

2. Click Next 

3. Wait for the action to finish 

4. Click Finish 

MODEL SIZE 

This warning dialog may appear if the imported model exceeds the size limits concerning imported model units. 

That may negatively affect its appearance when displayed in Misterine App. 

1. Select the proper model units in the drop-down menu. 

2. Click OK 
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Figure 21 Model size dialog 

INSERT POSITIONING NODE 

1. Right click the one of the selected nodes in the Scene Explorer 

2. Choose Insert positioning node above 

This operation can be done only with models and other positioning nodes. 

INSERT EMPTY NODE 

It’s easier to compose transformation over multiple nodes than trying to compute single transformation and fill in 

rotation, position, and scale manually. Empty nodes can also be used for grouping multiple objects. 

1. Open the Scene Explorer context menu 

2. Choose Insert empty node 

SEPARATE GEOMETRY 

Sometimes hierarchy nodes have geometry on them in addition to things below it. You may want to animate the 

geometry that is on this node independently of the parts below it, for instance for assembly/disassembly. 

1. Open the node context menu 

2. Choose Separate geometry 

FLIP NORMALS/FACES 

1. Right click the model node in the Scene Explorer 
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2. Choose Flip normals/Flip faces 

This operation can be done only with models and other positioning nodes. 

 

MODEL IMPORT ISSUES TROUBLESHOOTING 

FIXING MODEL ISSUES 

1. Open Preferences 

2. Navigate to Scene -> Model import – 3D Model formats 

3. Toggle the needed settings 

LIGHTING ISSUES 

1. Open Preferences 

2. Navigate to Scene -> Model import – 3D Model formats 

3. Enable Attempt to fix inward-facing normals 

or 

1. Check normals by toggling Render face normals or Render vertex normals 

2. Modify the object in 3D editor of your choice 

 

TRACKING MARKERS 

CREATE TRACKING MARKER 

1. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

SNAP TRACKING MARKER TO OBJECT SURFACE  

1. Select a tracking marker in the Scene Explorer or the Scene View 

2. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

a. Click and hold the left mouse button 

b. Place the cursor to the position over an object where you want to snap the tracking marker 

c. Release the left mouse button to finish snapping 

or 

a. Place the cursor to the position over an object where you want to snap the tracking marker 

b. Click the left mouse button to perform snapping 
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SET TRACKING MARKER ID 

1. Select a tracking marker in the Scene Explorer or the Scene View 

2. Enter the tracking marker ID value in the Property Editor 

 

Figure 22 Set tracking marker  ID 

SET TRACKING MARKER PHYSICAL SIZE  

1. Select a tracking marker in the Scene Explorer or the Scene View 

2. Enter the tracking marker physical size in the Property Editor 

 

Figure 23 Set tracking marker physical size 

SAVE TRACKING MARKER TO PDF 

1. Select a tracking marker in the Scene Explorer or the Scene View 

2. Click the  button in the Property Editor 

3. Select the destination location and PDF file name 

4. Click Save 

DISPLAY TRACKING MARKER IN PDF 

1. Select a tracking marker in the Scene Explorer or the Scene View 

2. Click the  button in the Property Editor 

 

INTERACTIVE ANCHORS 

CREATE INTERACTIVE ANCHOR 

1. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

There can be only one interactive anchor per scene. 

SNAP INTERACTIVE ANCHOR TO OBJECT SURFACE  

1. Select an interactive anchor in the Scene Explorer or the Scene View 
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2. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

a. Click and hold the left mouse button 

b. Place the cursor to the position over an object where you want to snap the interactive anchor 

c. Release the left mouse button to finish snapping 

or 

a. Place the cursor to the position over an object where you want to snap the interactive anchor 

b. Click the left mouse button to perform snapping 

 

LABELS 

CREATE LABEL 

1. Select an object in the Scene Explorer or the Scene View 

2. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

3. Enter the label text 

4. Click OK 

MOVE LABEL ANCHOR ON THE OBJECT  

1. Select a label in the Scene Explorer or the Scene View 

2. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

a. Click and hold the left mouse button 

b. Place the cursor to the position over an object where you want to move the label anchor 

c. Release the left mouse button to finish moving 

or 

a. Place the cursor to the position over an object where you want to move the label anchor 

b. Click the left mouse button to perform moving 

Label anchor can be moved only on the object the label is attached to. 

While in using this tool, it is possible to select the related object by Alt-clicking the label in 3D view. 

SELECT RELATED OBJECT 

1. Select a label 

2. Right click in Scene Explorer to open context menu 

a. Click Select referenced object to select only the related object 
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or 

a. Click Add referenced object to selection to preserve current selection 

SET LABEL TEXT 

1. Select a label in the Scene Explorer or the Scene View 

2. Enter the label text in the Property Editor 

 

Figure 24 Set label text 

 

NOTES 

CREATE NOTE 

1. Click the  button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

2. Select preferred aspect ratio for the note 

3. Click OK 

SET NOTE SIZE  

1. Select a note in the Scene Explorer or the Scene View 

2. Enter the note size in the Property Editor 

 

Figure 25 Set note size 

ORIENT NOTE TO USER 

1. Select a note in the Scene Explorer or the Scene View 

2. Click the button to enable/disable note orientation to user 

 

Figure 26 Orient note to user 

ADD NOTE TEXT 

1. Select Text in the Note editor toolbox on the right side 
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2. Click wherever on the note area to add the text element 

3. Click multiple times to add another text elements or right-click to finish adding 

4. Click created text element to select it 

5. Enter custom text 

ADD NOTE IMAGE 

1. Select Image in the Note editor toolbox on the right side 

2. Click wherever on the note area to add the image element 

3. Click multiple times to add another image elements or right-click to finish adding 

4. Click created image element to select it 

5. Click Choose image… to add specific image 

6. Choose from already imported images or click  to add a new one 

RESIZE TEXT/IMAGE ELEMENT 

1. Click text/image element to select it 

2. Choose one of eight resize handlers 

3. Click and hold the chosen resize handler  

4. Optionally press and hold the Shift key to keep current aspect ratio of the selected element  

5. Change size of the element by dragging mouse until the required size is achieved 

6. Release the mouse to finish resizing 

or 

1. Click text/image element to select it 

2. In the top bar change width or height of the selected element 

3. Optionally click  button to keep current aspect ratio of the selected element 

MOVE TEXT/IMAGE ELEMENT 

1. Click text/image element to select it 

2. Click and hold the edge of the selected element (for image, the whole area is available for the click) 

3. Move it by moving mouse to required location 

4. Release mouse to finish moving 

or 

1. Click text/image element to select it 

2. In the top bar change horizontal or vertical position of the selected element 
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ZOOM 

1. Move mouse cursor to point of interest 

2. Mouse wheel up/down to zoom in/out 

or 

1. In the top bar click  button to zoom in,  button to zoom out or  button to reset zoom to 

100% 

CHANGE Z-ORDER 

1. Right-click text/image element required to change a z-order to 

2. Choose one of the z-order changing options 

a. Bring to Front for changing z-order to be in front of all other elements 

b. Bring forward for changing z-order to be one step closer to the front 

c. Send to Back for changing z-order to be behind all other elements 

d. Send backward for changing z-order to be one step farther from the front 

or 

1. Click text/image element required to change a z-order to 

2. In the top bar click 

a.  button to bring it to front 

b.  button to bring it forward 

c.  button to send it backward 

d.  button to send it to back 

 

CHANGE BACKGROUND COLOR OF NOTE 

1. Select note in Scene Explorer or Scene View 

2. Open Note Editor 

3. Click  in toolbar at the top of the Note Editor 

4. Pick desired color for the background 

Default Note background color is white. 

CHANGE BACKGROUND COLOR OF TEXT NOTE 

1. Select Text Note in Note Editor 

2. Click  

3. Pick desired color for the background 
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Default Text Note color is transparent. 

 

SCENE EXPLORER 

HELPER SCENE GRAPH FUNCTIONALITY 

Navigation in a complex scene graph can get difficult fast. To accomplish this, we offer several helper functions. 

COLLAPSE NODES 

1. Right click to open context menu 

2. Select Collapse and then what should be collapsed 

EXPAND NODES 

1. Right click to open context menu 

2. Select Expand and then what should be expaned 

SCOPE TO THIS 

To show only the selected objects, it’s possible to scope to them. Only the path to the objects will be expanded, all 

other nodes are collapsed. 

1. Right click to open context menu 

2. Select Scope to this 

HELPER SELECTION FUNCTIONALITY  

It can be hard to find objects in the hierarchy and to help with this, it’s possible to select first visible, invisible, or 

animated object in the hierarchy. 

1. Right click to open context menu 

2. Select Select up -> Animated, Visible, Invisible 

 

SCENE VIEW 

CENTER ON SELECTION 

1. Click the   button in the Scene Designer toolbar or use the keyboard shortcut specified in Keyboard 

Shortcuts 

SWITCH SCENE LAYOUT 

1. Click the   button in the Scene Designer toolbar to switch to a 4-view layout or use the keyboard 

shortcut specified in Keyboard Shortcuts 
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or 

1. Click the   button in the Scene Designer toolbar to switch to a perspective view or use the keyboard 

shortcut specified in Keyboard Shortcuts 

RENDER FACE NORMALS 

1. Click the   button in the Scene Designer toolbar to render face normals or use the keyboard shortcut 

specified in Keyboard Shortcuts 

RENDER VERTEX NORMALS 

1. Click the   button in the Scene Designer toolbar to render vertex normals or use the keyboard 

shortcut specified in Keyboard Shortcuts 

SHOW/HIDE GRID 

1. Click the   button in the Scene Designer toolbar to hide grid or use the keyboard shortcut specified in 

Keyboard Shortcuts 

or 

1. Click the   button in the Scene Designer toolbar to show grid or use the keyboard shortcut specified 

in Keyboard Shortcuts 

CHANGE BACKGROUND COLOR 

1. Click the color picker in the Scene Designer toolbar 

2. Choose the proper color in a color picker 

3. Click OK 

SHOW/HIDE LAYER 

1. Click one of the following buttons  in the Scene Designer toolbar 

• B – Background 

• T – Tracking 

• C – Context 

• F – Foreground 

CHANGE SCENE VIEW ORIENTATION  

1. Click the drop-down menu in right up corner of the selected view in the Scene View 

2. Select the proper orientation 
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Figure 27 Change scene view orientation 

TAKE SCENE VIEW SNAPSHOT 

1. Select the desired scene view (if the 4-view layout view is enabled) 

2. Click the  button in the Scene Designer toolbar 

3. Click the  button to pick the destination folder 

4. Enter the resource name 

 

Figure 28 Enter scene view snapshot name 

5. Select the image format using a drop-down menu 

 

Figure 29 Select scene view snapshot image format 

6. Select the image aspect ratio using a drop-down menu 

 

Figure 30 Select scene view snapshot aspect ratio 

a. If the Custom option was selected, enter custom aspect ratio values 
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Figure 31 Select scene view snapshot custom aspect ratio 

7. Select the target resolution using a drop down-menu 

 

Figure 29 Select scene view snapshot target resolution 

a. If the Custom option was selected, enter custom Width and Height values 

 

Figure 320 Select scene view snapshot custom target resolution 

b. Click the  button to keep proportions if needed 

8. Click Save 
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Figure 31 Take scene view snapshot 

 

SHOW SCENE STATISTICS  

9. Click the button in the right side of the Scene Designer status bar 

 

Figure 33 Scene statistics button 

 

ANIMATIONS 

CREATE NEW ANIMATION 

1. Select an object 

2. Press the  button to create an animation with an empty track. 

or 
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1. Right click on the object in Timeline. 

2. Pick animation from the context menu. 

MOVE CLIP 

1. Hover over the clip. 

2. Press left mouse button. 

3. Drag left and right. 

MOVE CLIP BETWEEN TRACKS  

1. Press Alt and left mouse button over the clip. 

2. Drag it up/down. 

RESIZE CLIP 

1. Hover over the circle at the start/end of the clip. 

2. Press left mouse button. 

3. Drag left and right. 

or 

1. Select the clip. 

2. Type the specific values in the Animator. 

COPY CLIP 

1. Select the clip. 

2. Press Ctrl+C. 

3. (Optional) Change the current time. 

4. Highlight a target track. 

5. Press Ctrl+V. 

MOVE TRACK 

1. Use the  buttons to move the track up/down. 

or 

1. Hover over the track name. 

2. Drag the track up/down. 

DELETE CLIP 

1. Right click over a clip. 

2. Select Delete from the context menu. 
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or 

1. Right click over a clip. 

2. Press D to select the context menu item. 

or 

1. Select a clip. 

2. Press Delete on your keyboard. 

DELETE TRACK 

1. Press the  next to the track name. 

or 

1. Right click on the track name. 

2. Select Delete from the context menu. 

SPLIT KEYFRAMED CLIP 

1. Open context menu for a keyframed clip (the red-colored) 

2. Select Split at current time 

CREATE KEYFRAMES 

1. Select a keyframed clip (the red-colored). 

2. Press Edit button in the Animator. 

3. Set the animator time (red). 

4. Create keyframe 

a. Hit K on your keyboard to animate all. 

or 

a. Right click on a property in the Animator. 

b. Select Set key from the context menu. 

or 

a. Modify a property using a gizmo or Property editor. 

CLEAR KEYFRAMES 

1. Right click on a channel to clear. 

2. Select Clear keyframes from the context menu. 

DELETE KEYFRAME 

3. Right click on a keyframe. 

4. Select Delete from the context menu. 
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SAMPLING SPECIFIC TIME  

1. Set the time in the Timeline (grey indicator) 

2. Set the time in the Animator (red indicator) 

3. Create keyframe 

MOVING IN TIMELINE 

1. Jump to clip endpoints using . 

Or 

1. Move the time by clicking on the time axis and dragging. 

Moving both a clip and the time marker in Timeline can be snapped to endpoints by pressing Shift. 

 

ANIMATION IMPORT 

SIMPLIFYING IMPORTED ANIMATIONS 

1. Open Preferences 

2. Navigate to Scene -> Animation import – Simplify 

3. Set your preferred method (default Adaptive) 

4. Delete and import the object again 

 

ASSETS 

CREATE TOOL ASSET 

4. Copy the model file to the Assets/Tools directory located in the project folder 

5. Click the  button in the Asset Explorer toolbar to refresh the asset list 

CREATE MATERIAL ASSET 

1. Right click the material in the Material Explorer under the proper tab 

2. Choose Create asset 

3. Enter a unique material asset name 

4. Click OK 

CREATE ANIMATION ASSET 

1. Right click the animation in the Timeline 

2. Choose Save animation as Asset 
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3. Enter a unique animation asset name 

4. Click OK 

CREATE CLIP ASSET 

1. Right click the clip in the Timeline 

2. Choose Save clip as Asset 

3. Enter a unique clip asset name 

4. Click OK 

CREATE ASSET FROM HIERARCHY 

1. Open context menu for the root node of the hierarchy subtree you want to save as an asset. 

2. Choose Save as Asset 

3. The asset will be stored in Asset Explorer -> Models 

ADD MODEL/TOOL ASSET TO SCENE  

1. Right click the model/tool asset in the Asset Explorer 

2. Choose Add to scene 

or 

1. Drag & Drop the model/tool asset from the Asset Explorer into the Scene Explorer or the Scene View 

DELETE ASSET 

1. Right click the asset in the Asset Explorer 

2. Choose Delete 

or  

1. Select the asset in the Asset Explorer 

2. Press Delete key 

Model assets can be deleted only if they are not used in any scene. 

APPLY ANIMATION ASSET 

1. Drag & Drop the animation asset from the Asset Explorer into the Timeline to add the animation at the 

time under the cursor 

or 

1. Right click the animation asset in the Asset Explorer 

2. Choose Add to timeline to add the animation at the current time 
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APPLY CLIP ASSET 

1. Drag & Drop clip asset from the Asset Explorer into animation/track in the Timeline to add the clip at the 

time under the cursor 

or 

1. Right click the clip asset in the Asset Explorer 

2. Choose Add to timeline to add the clip to animation/track at the current time 

 

MATERIALS 

CREATE MATERIAL 

1. Click the  button in the Material Explorer toolbar 

DELETE MATERIAL 

1. Select the material in the Material Explorer under the proper tab 

2. Click the  button in the Material Explorer toolbar 

or 

1. Right click the material in the Material Explorer under the proper tab 

2. Choose Delete material 

Only unused materials and material assets can be deleted. 

APPLY MATERIAL TO SELECTION 

1. Right click the material in the Material Explorer under the proper tab 

2. Choose Assign to selection 

or  

1. Select the material in the Material Explorer under the proper tab 

2. Click the  button in the Material Explorer toolbar 

ADD RELATED OBJECTS TO SELECTION 

1. Right click the material in the Material Explorer under the proper tab 

2. Choose Add related objects to selection 

or 

1. Select the material in the Material Explorer under the proper tab 

2. Click the  button in the Material Explorer toolbar 
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Only used materials have related objects. 

 

 

APPLY MATERIAL TO 3D OBJECT 

1. Drag & Drop the material asset from the Material Explorer under the proper tab on the proper object in 

the Scene View 

RENAME MATERIAL 

1. Click the text input field of the material in the Material Explorer under the proper tab 

2. Enter a unique material name 

 

Figure 34 Rename material 

Material assets cannot be renamed. 

SET MATERIAL SHADER TYPE 

1. Click the drop-down menu of the material in the Material Explorer under the proper tab 

2. Choose the proper shader type 

or 

1. Select an object in the Scene Explorer or the Scene View 

2. Click the drop-down menu of the material in the Property Editor in the Materials group 

3. Choose the proper shader type 

4. A dialog appears if the modified material is used by other objects not in the selection 

5. Click Yes if you want to modify all occurrences of the material or click No if you want to update just the 

occurrences within the selection 

 

Figure 35 Set material shader type 

SET MATERIAL COLOR 

1. Click the color picker of the material in the Material Explorer under the proper tab 

2. Choose the proper color in a color picker 
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3. Click OK 

or 

1. Select an object in the Scene Explorer or the Scene View 

2. Click the color picker of the material in the Property Editor in the Materials group 

3. Choose the proper color in a color picker 

4. Click OK 

5. A dialog appears if the modified material is used by other objects not in the selection 

6. Click Yes if you want to modify all occurrences of the material or click No if you want to update just the 

occurrences within the selection 

 

Figure 36 Set material color 

The material color changes are reflected in the Scene View and also can be previewed in the Material Preview. 

REPLACE MATERIAL  

1. Select an object in the Scene Explorer or the Scene View 

2. Click the  button of the material in the Property Editor in the Materials group 

3. Select the material the to replace with in the Select material dialog under the proper tab 

4. Click OK 

FILTER MATERIALS BY NAME 

1. Click the text input field in the Material Explorer toolbar 

2. Enter the filter text 

 

Figure 37 Filter materials by name 

FILTER MATERIALS IN VISIBLE LAYERS  

1. Click the  button in the Material Explorer toolbar 
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FILTER TEXTURED MATERIALS 

1. Click the  button in the Material Explorer toolbar 

FILTER MATERIALS IN SELECTION  

1. Click the  button in the Material Explorer toolbar 

FILTER MATERIALS BY SHADER TYPE  

1. Click the button in the Material Explorer toolbar 

2. Select the proper shader type in the drop-down menu 

FILTER MATERIALS BY THE GIVEN NUMBER OF SHARING NODES  

1. Click the  button in the Material Explorer toolbar 

2. Enter the number of sharing nodes 

3. Select the proper comparison operator from the drop-down menu 

RESET ALL MATERIAL FILTERS  

1. Click the   button in the Material Explorer toolbar 

 

COPYING OF PROPERTIES 

To make scene creation faster, some properties can be copied from a single item to one or more other items in 

Scene Explorer. Properties that can be copied are Materials and Animation. 

SET A SOURCE 

1. Right click an item in Scene Explorer 

2. Click Copy properties 

The option is available only for item, that can be potentially an owner of at least one copyable property. 

COPY PROPERTIES 

1. Select one or more items the properties will be copied to 

2. Right click one of the selected items 

3. Click Paste properties 

4. In the open dialog choose properties to copy 
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5. Click OK to start copying 

The option is available only if a source is set and if the source has at least one property that can be copied to all 

selected items.  
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PROCESS VALIDATION  

Before deployment all processes must be validated. This validation is triggered automatically before every 

deployment and will disallow any progress until all validation issues are resolved. 

 

SHOW VALIDATION STATUS 

There are several ways to observe the current state of the opened process. 

TRIGGER VALIDATION AND DISPLAY RESULTS 

1. Right click the process in Project Explorer 

2. Choose Validate Process 

The validation result is displayed in a dialog window. 

DISPLAY CURRENT VALIDATION STATUS (DIALOG) 

The validation preview at the bottom right corner of the screen shows the current number of warnings and errors 

in the opened process. 

Click the button for detailed dialog window. 

DISPLAY CURRENT VALIDATION STATUS (PANEL)  

Double click the warning / error in the validation panel to navigate to the invalid element. 

Navigation is not available for all types of validation errors. 
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SCENE VALIDATION 

As for the process, each scene also must be validated. This validation is triggered automatically when a change 

occurs in the scene, or during deployment. Any error will disallow further progress until fixed. 

SHOW VALIDATION STATUS 

All validation results are shown in the process validation as well. To see scene specific results, open the scene and 

navigate to Validation tab under Property Editor. 
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PROCESS DEPLOYMENT 

To use processes in Misterine App, the processes must first be deployed. Misterine Studio provides several options 

of process deployment. 

DEPLOY TO THE EMBEDDED SERVER  

1. Right click the process in Project Explorer 

2. Choose Deploy Process 

or 

1. Select the process in Project Explorer 

2. Go to Process > Deploy Process 

3. Select Embedded Server as a destination and click Next 

4. Wait for the operation to complete 

The package is only available while the Overview deployment screen is opened. 

DEPLOY TO THE ONLINE SERVER 

1. Right click the process in Project Explorer 

2. Choose Deploy Process 

or 

1. Select the process in Project Explorer 

2. Go to Process > Deploy Process 

3. Select Application Server as a destination 

4. Select specific application server from the list and click Next 

5. Log in if not logged in already and click Next 

6. Select a target directory from list of available directories on the server and click Deploy 

7. Wait for the operation to complete 

The default online server is https://public.misterine.com 

ADD NEW CUSTOM DEPLOYMEN T SERVER 

1. Go to Edit > Preferences > Deployment 

2. Click Add custom server 

3. Enter name and address 

4. Click Update to confirm changes 

This feature is not available in Misterine Personal Edition. A special Misterine Studio license can disable this 

feature too. 
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PROCESS EXPORT 

Processes in Misterine Studio can be exported to the HTML format. 

EXPORT PROCESS TO HTML 

1. Right click the process in Project Explorer 

2. Choose Export Process to HTML 

or 

1. Select the process in Project Explorer 

2. Go to Project > Export > Export Process to HTML 

3. Choose destination for the exported folder 

4. Click Select Folder 

5. Wait for the operation to complete 

Only valid processes may be exported. 

Result of the export is put into a new folder. 

SETUP EXPORT CSS FILE  

1. Go to Edit > Preferences > Export > HTML Export 

2. Enter or paste in the CSS code  

CSS style may be reset to default by clicking the Reset to Default button. 
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APPENDIX 

KEYBOARD SHORTCUTS 

 

Project Explorer 

UP Select project item below the last selected project item 

DOWN Select project item above the last selected project item 

SPACE Expand / Collapse folder 

DELETE Delete selection 

CTRL + C Copy project item (only for Process) 

CTRL + V Paste project item (only for Process) 

CTRL + D Duplicate project item (only for Process) 

 

Process Editor 

CTRL + C Copy current selection 

CTRL + V Paste copied selection on a mouse position or on a position of a source with an offset (if mouse 

is not over edit area) 

CTRL + D Duplicate current selection 

DELETE Delete current selection 

CTRL + Z Undo 

CTRL + Y Redo 

ESC or RMB Cancel node creating action if it’s in progress 

Mouse 

wheel 

Zoom in / out 

 

Validation 

UP Select validation item above currently selected validation item 

DOWN Select validation item below currently selected validation item 

ENTER / Double LMB Navigate to a place relative to selected validation item 

 

 

Rich Text Editor 

CTRL + B Make text bold 

CTRL + I Make text italic 

CTRL + U Make text underlined 
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CTRL + = Make text subscripted 

CTRL + SHIFT + = Make text superscripted 

CTRL + SPACE Open popup with suggestions 

UP Move to a suggestion above currently selected suggestion (only Suggestions popup) 

DOWN Move to a suggestion below currently selected suggestion (only Suggestions popup) 

ENTER Confirm currently selected suggestion (only Suggestions popup) 

 

Scene Editor   

CTRL + F Focus the search field (type in and press Enter to search) 

CTRL + I Import a model 

CTRL + Z Undo 

CTRL + Y Redo 

CTRL + 1 Add a tracking marker 

CTRL + 2 Add an interactive anchor 

CTRL + 3 Add a label to the selection 

CTRL + 4 Add a note 

CTRL + SHIFT + M Show / Hide radial menu 

ALT + C Move the selection to origin 

ALT + L Select connected objects 

CTRL + H Hide selected 

CTRL + SHIFT + H Show selected 

CTRL + SHIFT + I Inverse selection 

Q Select tool 

W Translate tool 

E Rotate tool 

R Scale tool 

T Snapping tool 

Y Move label line start position 

F Focus on selection (focus all if nothing is selected) 

DELETE Delete selected object (if in a text field, it works on the text inside; if clip is selected 

then the clip is deleted first) 

CTRL + DELETE Dissolve selected object (removes the node but tries to reparent the children). 

CTRL + A Select all 

CTRL + SHIFT + A Select all that is visible (based on the state of an object) 
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CTRL + D Deselect all 

CTRL + V Insert a model (only if an object file in Windows Explorer is selected and copied before) 

LMB Select object in the scene / Deselect all 

CTRL + LMB Toggle selection 

SHIFT + LMB Add to selection 

ALT + LMB Select common parent of the current selection when clicked on 

RMB Rotate around a target (displayed as a small red sphere). If the mouse is over an object, 

the target is the 3D point under the mouse cursor. While rotating, the red sphere is 

connected to its projection to XZ plane with yellow line.  

Shift + LMB + 

Vertical mouse 

movement 

Zoom to an object under the mouse (if any), or to the target (red sphere) 

Mouse wheel Zoom to center 

RMB + Mouse wheel Zoom to the center of rotation 

CTRL + Space Toggle between multi-view layout and single-view layout 

 

Scene Explorer 

CTRL + RIGHT Move the horizontal scrollbar to the right 

CTRL + LEFT Move the horizontal scrollbar to the left 

SHIFT + SCROLL Move the horizontal scrollbar 

CTRL + UP Move the focus up 

CTRL + DOWN Move the focus down 

SHIFT + UP/DOWN 
Add to selection when moving from focused object. Removes from selection when 

going back. 

RIGHT Expand an assembly 

LEFT Collapse an assembly 

UP Select the node up from the current one 

DOWN Select the node down from the current one 

CTRL + SPACE Select / Deselect focused object. 

CTRL + ENTER Select / Deselect focused object. 

HOME Select the first object in the tree 

END Select the last object in the tree 

CTRL + HOME Focus the first object in the tree 

CTRL + END Focus the last object in the tree 

SHIFT + HOME Select all between last focused and top of the tree 
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CTRL + C Copy selection 

CTRL + X Cut selection 

CTRL + V Paste selection 

SHIFT + END Select all between last focused and end of the tree 

CTRL + G Creates new Named Selection Set from current selection 

 

Animator 

K Create keyframe at current time 

C Set the time to current time (Clip start/end time input field must be focused)  

 

Timeline 

CTRL + C Copy the selected clip 

CTRL + V Paste the content of clipboard to highlighted track at current time – can be, for example, a 

selected clip (if the clipboard content is incompatible to paste, nothing happens)  

CTRL + Drag Duplicate and move the clip 

ALT + Drag Move the clip between tracks 

SHIFT + Drag Snap the clip to clip’s endpoints, 0, and current time 

 

History 

HOME Focus on the first object in the history 

END Focus on the last object in the history 

UP Focus on node up from the top 

DOWN Focus on node down from the top 

SPACE Move to this point in history 
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SCENE EXPLORER FILTERING 

Scene Explorer offers basic filtering of items based on their name, or special filters for more restrictive filtering. All 

possible filters are listed in a table below. 

 

:m {VALUE} Filters meshes with name containing {VALUE} 

:nm {VALUE} Filters non-meshes with name containing {VALUE} 

:tm {VALUE} Filters tracking markers with name containing {VALUE} 

:ia {VALUE} Filters interactive anchors with name containing {VALUE} 

:l {VALUE} Filters labels with name containing {VALUE} 

:a {VALUE} Filters nodes with animations with name containing {VALUE} 

:ma {VALUE} Filters nodes with materials with name containing {VALUE} 

:n {VALUE} Filters notes with name containing {VALUE} 

:v {VALUE} Filters visible objects with name containing {VALUE} 

:h {VALUE} Filters hidden objects with name containing {VALUE} 

:s {VALUE} Filters selected objects with name containing {VALUE} 

:ns {VALUE} Filters objects in a group with name containing {VALUE} 

:{KEY} 

{VALUE} 

Filters nodes with property key containing {KEY} and with property value containing {VALUE} 

(only for models imported from JT file) 

 

If {VALUE} is unspecified, the related restriction is ignored 

Example: 

 

:tm filters all Tracking Markers 

:tm Marker1 filters all Tracking Markers with name containing Marker1 

:number filters all items with property key containing number  

:number 123 filters all items with property key containing number and with property value containing 123  
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GENERAL LIMITATIONS 

LISTS 

• A list item is limited to one para element 

• List types have to be the same on the same level. 

• Indenting list, while the cursor is on the first item, causes indentation for the whole list, not a level shift 

• Only simple numbering is supported (nested lists start again from 1) 

• Deleting the first item in lists will cause inconsistent numbering 

• It is possible to create scattered lists (lists interrupted by text) but they will be unscattered in the next 

session 

• Titles are not supported 

TABLES 

TABLE STRUCTURE 

• We do not support cell rotation 

• We support only % column spacing 

• The widths of columns are supported for the whole table, not individual rows 

• Support for irregular tables is limited (irregular tables are turned into rectangular ones) 

TABLE PLACEMENT 

• Tables cannot have margins 

• Tables inside lists cannot have an indentation 

• Tables inserted as first list item will be added before the list 

TABLE SELECTION 

• Multiple cell selection and typing behavior is inconsistent (when selectin from bottom-up / from top to 

bottom) 

• Column selection causes scrolling 

TABLE BEHAVIOR 

• Pressing enter at the beginning of the very first cell causes a new line to appear above the table 

• Manually set row height is not preserved 

• Tables created inside lists will inherit lists in all its cells 

• Tables created inside lists split the list and add another empty item 

• Pressing TAB creates in the last cell creates a new row with the same options (formatting and lists, etc.) 
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TABLE COPY & PASTE 

• Cut and pasted tables that are being referenced will lose the reference 

SCROLLING 

• Horizontal scrollbar is displayed even when content decreases in width 

• Horizontal is only displayed when Vertical scrollbar is at the very bottom 

HYPERLINKS 

• Links appear to have format applied to them, but it is lost in next session 

SELECTION 

• Selecting a format that changes caret style (italic) and navigating elsewhere does not clear the style 

3D MODELS 

• Limit of 41.5 million triangles on a single mesh on import 

• Max size of a scene for deployment to the newest generation of iPad is ~4.5 million triangles.  
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S1000D LIMITATIONS 

LISTS (RANDOM/SEQUENTIAL/ATTENTIONRANDOM/ATTENTIONSEQUENTIAL)  

• A list item is limited to one para element 

• List types has to be the same on the same level. 

• Only simple numbering is supported (nested lists start again from 1) 

• Titles are not supported 

STYLES 

• Emphasis can be converted to character styles (bold, italic, ...) when parsing from S1000D. 

Information about emphasis in not being kept from that point forward in the deployment process. 

LINKS 

• Internal reference to anything other than steps, figures, supplies, equipment, spares, & Tables 

TABLES 

• Tables cannot be embedded in tables 

• We do not support cell rotation 

• We support only % column spacing 

• Groups are not supported 

• The widths of columns are supported for the whole table, not individual rows 

• Tables cannot have margins 

• Tables inside lists cannot have indentation 

• We do not support tgstyle tag for Business Rules and standard table types (see BRDP-S1-00121) 

• Vertical justification not supported 

• Support for irregular tables is limited 

• Warnings and Cautions are not supported 

RICH TEXT 

• Acronyms: we do not support bullet points inside of acronyms 

• Acronyms: we do not support rich text (superscript, subscript) in acronym search 

• Inline images are not supported 


	Introduction
	System Requirements
	Installation
	Install Misterine studio
	Upgrade Misterine studio
	Uninstall Misterine studio

	Update Installation
	Install Update
	Ignore Update

	License
	Online activation
	Online deactivation
	Online refresh
	Manual activation
	Manual Deactivation
	Manual Refresh

	User Interface Overview
	Project Management
	Project
	Create a new project
	Open an existing project
	Open a recently opened project
	Close the currently opened project

	Resources
	Import resources to project
	Create subfolders for resources
	Set resource access rights
	Preview resource


	Process Definition
	Process Management
	Create new empty process
	Create process from imported text resource
	Create process from imported S1000D resource
	Create process from S1000D file on disk
	Resolve missing image during S1000D file import
	Resolve by creating a new resource
	Resolve using existing resource

	Open process

	Process Workflow Definition
	Add node into the process
	Delete node
	Duplicate node
	Connect nodes in sequence

	Task / Subprocess Details
	Add warnings / cautions to Task
	Reorder warnings / cautions

	Decision Point Details
	Add an output point
	Add a resolution method
	Add options to resolution method


	Process Details
	Process Thumbnail
	Add or change Process Thumbnail
	Delete Process Thumbnail

	Process Tags
	Create Tag
	Remove Tag

	Process Resources
	Add new process resource


	Scene Definition
	Scenes
	Create new scene
	Open scene
	Delete scene
	Propagate Scene

	Scene Templates
	Create scene template
	Open scene template
	Duplicate scene template
	Add scene template to an existing task
	Turn existing scene on a task into a scene template
	Mark a scene template as default


	Scene Interface Overview
	Scene Creation
	Scene Objects
	Select scene object
	Select connected objects
	Move scene object
	Set name
	Set layer
	Set visibility
	Show selected
	Hide selected
	Hide unselected
	Translate scene object
	Translate scene object using gizmo or move tool
	Rotate scene object
	Rotate scene object using gizmo or rotate tool
	Scale scene object
	Scale scene object using gizmo
	Store transformation
	Delete scene object
	Dissolve scene object
	Move selected objects to origin
	Decimate selected object(s)
	Select similar object(s)

	Named Selection Sets
	Create Selection Set
	Rename Selection Set
	Remove Selection Set
	Update Selection Set
	Select Selection Set

	Models
	List of supported model formats
	CAD exchange formats
	Supported 3D graphics formats

	Import new model
	Tessellation settings
	Model size
	Insert positioning node
	Insert empty node
	Separate geometry
	Flip normals/faces


	Model Import Issues Troubleshooting
	Fixing model issues
	Lighting issues

	Tracking Markers
	Create tracking marker
	Snap tracking marker to object surface
	Set tracking marker ID
	Set tracking marker physical size
	Save tracking marker to PDF
	Display tracking marker in PDF

	Interactive Anchors
	Create interactive anchor
	Snap interactive anchor to object surface

	Labels
	Create label
	Move label anchor on the object
	Select related object
	Set label text

	Notes
	Create note
	Set note size
	Orient note to user
	Add note text
	Add note image
	Resize text/image element
	Move text/image element
	Zoom
	Change z-order
	Change background color of note
	Change background color of Text Note

	Scene Explorer
	Helper Scene graph functionality
	Collapse nodes
	Expand nodes
	Scope to this

	Helper selection functionality

	Scene View
	Center on selection
	Switch scene layout
	Render face normals
	Render vertex normals
	Show/hide grid
	Change background color
	Show/hide layer
	Change scene view orientation
	Take scene view snapshot
	Show scene statistics

	Animations
	Create new animation
	Move clip
	Move clip between tracks
	Resize clip
	Copy clip
	Move track
	Delete clip
	Delete track
	Split keyframed clip

	Create keyframes
	Clear keyframes
	Delete keyframe
	Sampling specific time
	Moving in timeline

	Animation Import
	Simplifying imported animations

	Assets
	Create tool asset
	Create material asset
	Create animation asset
	Create clip asset
	Create asset from hierarchy
	Add model/tool asset to scene
	Delete asset
	Apply animation asset
	Apply clip asset

	Materials
	Create material
	Delete material
	Apply material to selection
	Add related objects to selection
	Apply material to 3D object
	Rename material
	Set material shader type
	Set material color
	Replace material
	Filter materials by name
	Filter materials in visible layers
	Filter textured materials
	Filter materials in selection
	Filter materials by shader type
	Filter materials by the given number of sharing nodes
	Reset all material filters

	Copying of Properties
	Set a source
	Copy properties


	Process Validation
	Show Validation Status
	Trigger validation and display results
	Display current validation status (dialog)
	Display current validation status (panel)


	Scene Validation
	Show validation status

	Process Deployment
	Deploy to the embedded server
	Deploy to the online server
	Add new custom deployment server

	Process Export
	Export process to HTML
	Setup export CSS file

	Appendix
	Keyboard Shortcuts
	Scene Explorer Filtering
	General Limitations
	Lists
	Tables
	Table structure
	Table placement
	Table selection
	Table behavior
	Table Copy & Paste
	Scrolling
	Hyperlinks
	Selection

	3D Models

	S1000D Limitations
	Lists (Random/Sequential/AttentionRandom/AttentionSequential)
	Styles
	Links
	Tables
	Rich Text



